Code Fix: When opening a workflow an XML error occurs after an Activity Outcome rule is changed

  • 16 February 2021
  • 0 replies
  • 19 views

Badge +5
 

Code Fix: When opening a workflow an XML error occurs after an Activity Outcome rule is changed

KB001829

PRODUCT
K2 blackpearl 4.7
BASED ON
K2 blackpearl 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue Description
When changing an Activity Outcome rule in a workflow by removing an inline method, deploying the workflow and attempting to open it again, an XML error occurs.

 

Error Message
An error has occurred while parsing the workflow XML.

Image

 

Cause
K2 did not clear the ValuePluginInput when a plugin (inline method) was removed, it was kept in the ProcessDefinitionXML which caused the XML error.

 

Repro Steps

  1. Create a Form in the K2 Designer.
  2. Add a Button control with the rule "if button is clicked, show message".
  3. Save the Form.
  4. Create a Workflow.
  5. Add a decimal data field.
  6. Configure the Outcome rule with: If Data Field = Inline function "Absolute [-1].
  7. Add a Placeholder in the outcome activity.
  8. Deploy the workflow.
  9. Change the Outcome rule to:  if Data Field = 0.
  10. Re-deploy the workflow.
  11. Close the workflow.
  12. When re-opening the workflow, the XML error occurs.

 

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Install the K2 4.7 February 2017 Cumulative Update.
  3. Get the K2 4.7 February 2017 Cumulative Update FP3 from Regional Support.
  4. Install the K2 4.7 February 2017 Cumulative Update FP3 to apply the fix.
  5. Clear the Browser Cache.

 


0 replies

Be the first to reply!

Reply