Code Fix: Adding more than two outcomes within the Default Client event causes an error

  • 16 February 2021
  • 0 replies
  • 9 views

Badge +6
 

Code Fix: Adding more than two outcomes within the Default Client event causes an error

KB001833

PRODUCT
K2 blackpearl 4.7
BASED ON
K2 blackpearl 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue Description
On the Default Client Event, if multiple outcomes are added manually an error occurs when adding the second manual outcome.
 

 

Error Message
Error message: An item with this display name already exists within this container.

 

Cause
The DisplayName for outcome items were not set when adding it to the UI.

  • The first outcome was auto-generated with a valid displayname (equal to its name).
  • When adding a new outcome, the name was saved as specified in the UI, but the DisplayName was still set as the default OutcomeItem.
  • Adding an additional outcome, failed with the specified error because it had the same default displayname of OutcomeItem.

 

Repro Steps

  1. Open K2 Studio.
  2. Create a project.
  3. Create a new process.
  4. Drag a Default Client Event onto the canvas.
  5. Select Next on the Event name and forms page.
  6. Select Next on Event notification.
  7. Select Next on Configure Actions to generate a default action.
  8. Notice the outcome generated based upon the action.
  9. Add a second outcome on the Configure outcomes page.
  10. Add a third outcome on the Configure outcomes page.
  11. The error “An item with this display name already exists within this container” occurs.

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Install the K2 4.7 February 2017 Cumulative Update.
  3. Get the K2 4.7 February 2017 Cumulative Update FP4 from Regional Support.
  4. Install the K2 4.7 February 2017 Cumulative Update FP4 to apply the fix.
  5. Clear the Browser cache.

 


0 replies

Be the first to reply!

Reply