Code Fix: Slow performance experienced when starting a workflow where the start option is based on a SharePoint event
KB001822
PRODUCTIssue Description
When creating a K2 for SharePoint application, including a workflow with the option to start when a SharePoint event occurs, the workflow takes a long time to start after the SharePoint event is executed.
Cause
One call per SmartObject was executed which results in high load volume.
Repro Steps
- Create a Custom List with forty Choice columns.
- Add one or two Lookup columns.
- Integrate the list with K2 to create Data and Workflow.
- Select a SharePoint event, such as “Add new item” as the Start Option for the workflow.
- Add a Placeholder event and Deploy the workflow.
- Add a new item in the Custom List to start a new instance.
- Notice it will take more than five minutes for the workflow to start.
Resolution
- Ensure you have K2 4.7 installed.
- Install the K2 4.7 February 2017 Cumulative Update.
- Get the K2 4.7 February 2017 Cumulative Update FP2 from Regional Support.
- Install the K2 4.7 February 2017 Cumulative Update FP2 to apply the fix.