< class="prominent-subhead ">

Code Fix: Unable to start a workflow using a Form with Anonymous authentication

~~repeating-content.html~~
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue Description

When the machine hosting the K2 server is configured in workgroup mode, designing a form with Anonymous authentication and using this form to start a workflow, results in an error when the workflow starts.

Error Message

The error states: “Server is not configured for Windows Authentication”.

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and install the K2 4.7 November 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 November 2017 Cumulative Update FP6 from Regional Support.
  4. Install the K2 4.7 November 2017 Cumulative Update FP6 to apply the fix.
  5. Add the following entry to <appSettings> section in the [INSTALLDIR]\K2 smartforms Runtime\ web.config file:
    • <add key=”NonIntegratedSecurityLabels”value=”K2SQL”/>
    • <add key=”ExplictAuthUser”value=”SQLUser”/>
    • <add key=”ExplictAuthUserPassword”value=”Password”/>
  6. Refresh the browser cache.