Issue Description

When creating a policy on a SmartObject in K2 Management, you can use Extend/Secure By on objects that are non-SmartBox SmartObjects. This is incorrect as you should only be able to do this on SmartBox SmartObjects and not Advanced SmartObjects.

Resolution

  1. Ensure you have K2 Five (5.2) installed.
  2. Download the K2 Five (5.2) FP2 from K2 Partner and Customer Portal.
  3. Install the K2 Five (5.2) FP2 to apply the fix.
  4. It is recommended to refresh the browser cache.