This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice This article is not considered official documentation for K2 software and is provided “as is” with no warranties.

Issue

After successfully removing a process from K2 Workspace and deleting all workflow versions and history, multiple errors appear in the event viewer pointing to the deleted process instances stating that they are not found. 

Symptoms

An error has occurred in a K2 for SharePoint component.

Error details: 25223 Process not found [Assembly]: SourceCode.EventBus.SharePoint15.ProcessStarter, Version=4.0.0.0, Culture=neutral, PublicKeyToken=16a2c5aaaa1b130d [Class]:

SourceCode.EventBus.SharePoint15.ProcessStarter.ProcessStarter [Method]: StartProcess [Stack trace details]: at SourceCode.Workflow.Client.InternalConnection.Call(ArchiveX ar, MessageType msgtype) at SourceCode.Workflow.Client.Connection.CreateProcessInstance(String ProcName, Int32 Version, String Layer) at SourceCode.EventBus.SharePoint15.ProcessStarter.ProcessStarter.StartProcess(String hostName, String connStr, String processFullname, String folio, Boolean synchronous, String fieldsXml, String impersonateUser, Int32 defaultVersion, Int32 priority) [Verbosity]: Detailed

Troubleshooting Steps

To resolve this issue please complete the following steps:

1. Go to the SmartObject tester tool > SmartObject Explorer > SharePoint 2013 > Select Site Collection > Management > List SmartObject and execute 'Get Lists' method to query the list that had this workflow.

2. Take note of the list ID.

3. Use the event SmartObject from the same location and execute 'Get event receivers'

4. Pass the list ID to query the events registered for this list.

5. Execute the 'Remove Specific Remote Event Receiver' method.