"0 error, 0 warning" error when deploying workflow with K2 Studio

  • 15 February 2022
  • 0 replies
  • 48 views

Userlevel 5
Badge +20
 

"0 error, 0 warning" error when deploying workflow with K2 Studio

kbt148781

PRODUCT
K2 Five
K2 blackpearl
BASED ON
K2 blackpearl (all)
TAGS
K2 Studio
This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.

Issue

Unable to deploy workflow from K2 Studio to K2 server and the following error appears:

"0 error, 0 warning"

Symptoms

Below is a screenshot of the error:
 

Image

 

Diagnosis:

The issue is caused by one of the following scenarios:

1. The environment you are deploying to might not have the correct Microsoft.NET development SDK or Targeting Pack installed.

2. The workflow might be targeted to a .NET framework version higher/lower than the one on the environment you are deploying to.

3. The workflow is using a referenced assembly.

4. The workflow might be targeted to .NET development SDK or Targeting Pack which is not installed on the environment you are deploying to.

Troubleshooting Steps

1. Verify that the .Net Framework is installed on the K2 Studio environment. In this example, the .Net Framework is 4.6.1.

 

2. Change the .K2proj file TargetFrameworkVersion to 4.6 and once the version is changed, redeploy the solution using K2 Studio. You can then attempt to package and deploy on the target server.

 

Please follow how-to these steps:

a. Open the *.k2proj file in Notepad++

b. Find the following entry:

 

<targetframeworkversion>v4.0</targetframeworkversion>

or

<targetframeworkversion>v3.5</targetframeworkversion>

 

c. Change that to the following: v4.6

d. Save the *.k2proj file

e. Open this in K2 Studio.

f. Deploy the workflow which should no longer show any errors.


0 replies

Be the first to reply!

Reply