Introduction

K2 smartforms 1.0.4 (4.12165.1595.0) updates all versions of K2 smartforms installations with the latest product hotfixes, as detailed below.

New Requirements:

  1. The .NET Framework 4.5 is now required for the Design Time and Runtime sites. Ensure that the .NET Framework 4.5 is installed before installing or upgrading to K2 smartforms 1.0.4. In a distributed environment the .NET Framework 4.5 only has to be installed on the SmartForms web servers. The .NET Framework 4.5 installer can be located at:
  2. The SmartForms’ Application Pool must run on .NET Framework 4.5. If you have an existing SmartForms Application Pool running on the .NET Framework 3.5 (displayed as .NET Framework v2.0.50727 in IIS) and this application pool is used for other applications as well, a new application pool is required for K2 smartforms 1.0.4.  If you have an existing application pool running on the .NET Framework 3.5 that is only used for K2 smartforms, this application pool needs to be configured to run on the .NET Framework 4.5 (displayed as .NET Framework v4.0.30319 in IIS). Refer to http://msdn.microsoft.com/en-us/library/hh925568.aspx to know which .NET Framework is installed in your environment.

 

Update Options

There is one installer package for K2 smartforms 1.0.4 (4.12165.1595.0) available for download from portal.K2.com that will facilitate upgrades and clean installs.

  • For customers who already have K2 smartforms installed, download the package and install this update.
  • For customers who do not have K2 smartforms installed, download the package and follow the Setup Manager wizard.

New Features

The K2 smartforms 1.0.4 release contains new features which are described in the attached PDF.

Issues Resolved

The following issues have been fixed and are contained within this update:
KB001594 - K2 smartforms 1.0.4 High Priority Fixes

Behavioral Changes
In K2 smartforms 1.0.4 there has been a change in the behavior of the Picker control and SmartObject Method Parameters. Read the following KB articles to understand the possible impact of the changes:
KB001423 - Change in behavior relating to the transferring of values to the Picker control
KB001424 -Behavioral change in K2 smartforms 1.0.4 relating to SmartObject Method parameters

Previous Updates included in this release

This update includes all the new features and hotfixes that were included in the previous K2 smartforms Updates, so there is no need to install the updates listed below. The following links are provided for reference to view the enhancements and resolved issues contained within the previous updates:

KB001565 – K2 smartforms 1.0.1 (4.12165.1565.0) Release Notes

KB001575 – K2 smartforms 1.0.2 (4.12165.1575.1) Release Notes

Kb001585 – K2 smartforms 1.0.3 (4.12165.1585.0) Release Notes


Important Considerations

  1. For customers upgrading from pre K2 smartforms 1.0.2 versions must be aware that K2 smartforms 1.0.4 contains system configuration changes that will impact your existing environment. Be sure to carefully read through the release notes taking particular notice of the Important Considerations as well as any accompanying linked documentation.
  2. Adjustments have been made to various controls in this release and care has been taken to prevent breaking backwards compatibility. As a precaution K2 recommends that if you have applied custom themes to any Forms, extensive testing should be performed after upgrading to K2 smartforms 1.0.4 and before moving the Forms to Production to ensure that the Forms still function as previously designed. Support can be contacted if any issues are encountered during testing.
  3. K2 smartforms 1.0.4 has a dependency on K2 blackpearl 4.6.5 due to the email attachment feature which is reliant on the email functionality, workflow enhancements and enhancements to the Identity Services released in K2 blackpearl 4.6.5. 
  4. K2 recommends that for optimal performance the K2 smartforms Runtime Site should be running on the same server as the K2 Host Server.
  5. K2 smartforms now run on the Microsoft .NET 4.5 Framework.  The requirement is Microsoft .NET Framework 4.5 and Windows Identity Framework 3.5 SDK or Runtime.
  6. The SmartForms Integration and Client Event wizards will function as expected in Microsoft Visual Studio 2012.  
  7. To enhance the performance of SmartForms a change has been made to the Design time and Runtime site. The new requirement is that the Application Pool's Managed pipeline mode must be set to Integrated where previously it was set to Classic for both Design Time and Runtime. On upgrading to K2 smartforms 1.0.1, 1.0.2 or 1.0.3 a warning message will be displayed to inform the user that K2 will change the mode to Integrated for you. However, if other applications are dependent on the same Application Pool K2 will not change the mode but will rather inform the user that a new Application Pool needs to be created. The K2 blackpearl Application Pool account can no longer be used as it must be set to Classic mode.
  8. If you have deployed custom themes and custom controls in your environment refer to KB001376 - Performance changes made in K2 smartforms 1.0.2 which details changes that will need to be considered when upgrading to K2 smartforms 1.0.2, 1.0.3 or 1.0.4. These changes were implemented in 1.0.2 to improve performance. 
  9. If you are upgrading from K2 smartforms 1.0 or 1.0.1 note that adjustments were made to various controls in K2 smartforms 1.0.2 and these changes are also included in 1.0.3 and 1.0.4, care has been taken to prevent breaking backwards compatibility. As a precaution K2 recommends that if you have applied custom themes to any Forms, extensive testing should be performed after upgrading to K2 smartforms 1.0.4 and before moving the Forms to Production to ensure that the Forms still function as previously designed. Support can be contacted if any issues are encountered during testing.

Download

The K2 smartforms Setup Manager is available as an independent installation package that can be found at the following location:
K2 smartforms 1.0.4 (4.12165.1595.0) - https://portal.k2.com/downloads/k2smartforms

Installation Information

 New Prerequisites:

  • Microsoft .NET 4.5 Framework (installed on the SmartForms web servers)
  • K2 blackpearl 4.6.5 or higher
  • The Application Pool account for the K2 smartforms Design time and Runtime site's Managed pipeline must be set to Integrated and must be set to run on .NET Framework 4.5 (displayed as .NET Framework v4.0.30319 in IIS).

Recommendation: K2 recommends that the K2 smartforms Runtime Site is installed on the same server as the K2 Host Server to ensure optimal performance. If the K2 Server is load balanced then the smartforms runtime must also be load-balanced with the same number of nodes, For example,

K2 Farm K2 smartforms load balanced site 
Server 1      K2 Installed         K2 smartforms
Server 2 K2 Installed K2 smartforms
Server 3 K2 Installed K2 smartforms


For information on hardware and software prerequisites, installation steps on a standalone environment and post installation steps see:
Full Installation: KB001330 - Quick Guide to installing K2 smartforms or view the product documentation on help.k2.com.
Upgrade: KB001331 - Quick Guide to upgrading K2 smartforms. Remember to clear your browser cache after upgrading. 

Known Issues

A list of some of the current known issues that you may encounter when using K2 smartforms 1.0.4 (4.12165.1595.0) is available in:
KB001593 - K2 smartforms 1.0.4 (4.12165.1595.0) Known Issues List.
KB001414 – Known issues when using the field context of a Picker control for mappings or using the Picker control in an Editable List
KB001415 - Known issue: View and Form parameters overwriting field mappings